Setting up default domain - echp url not working anymore

When I have installed ehcp everyting works fine on http://www.mydomain.com/vhosts/ehcp/. The frontpage of mydomain.com shows
------------------
if you see this page instead of what you expect, you probably did not set up your domain on this server. Please log into your ehcp panel and set up your domain..or ask your admin/provider to do so...
----------------
So I log into ehcp and setup mydomain.com. But then the url to http://www.mydomain.com/vhosts/ehcp/ is no longer working (of course...).

What am I doing wrong?

You have done a common mistake:
Before you setup your domain at your server, you can see ehcp at http://www.yourdom.com/vhosts/ehcp
since www.yourdom.com is directed to apache webroot, which is ehcp webroot also, (/var/www/)

after you setup yourdom.com on your ehcp, then, www.yourdom.com is no longer directed to default apache webroot... instead, it is redirected to /var/www/vhosts/ftpuser/domain/httpdocs
so, you cannot see panel at http://www.yourdom.com/vhosts/ehcp , since there is no such dir under /var/www/vhosts/ftpuser/domain/httpdocs.

Correct:
to access your ehcp, use http://yourip/ such as http://232.122.222.22

if you wish to access ehcp from inside your domain, you need one of these:
1- dont setup your domain in ehcp, this way, your domain redirects to webroot of /var/www
2- first setup your domain in ehcp, then, move/copy all ehcp files under /var/www/vhosts/ehcp to any dir under /var/www/vhosts/ftpuser/domain.com/httpdocs/

ok? understand ?
hope this helps..

Thanks, that explains it :-)