I can not send and receive email from outside, but from a local works

I use ehcp, but why I can not send and receive email from outside ..?
I've tried to modify main.cf & master.cf to enable submission
I've tried various tutorials in ehcp forum, but it still does not work own.
Can you help my Own.?
I was desperate, and I've spent 14 hours to solve this problem, but it still does not work

Please check your log and find any error message on it.

# tail -f /var/log/mail.log

Now I can send out an email like gmail, ymail and etc.
but now I can not receive email from outside.
example, when I tried to send email from gmail to my web email but to no avail.
My port 25 is open.
but why I can only send emails out, but can not receive email from outside ..?

=================================
# Tail-f / var / log / mail.log
=================================
stikomcki root @ :/ home / stikomcki / ehcp # tail-f / var / log / mail.log
March 10 8:09:16 stikomcki imapd: LOGOUT, ​​user = admin@ckiweb.net, ip = [:: ffff: 127.0.0.1], headers = 0, body = 0, rcvd = 132, sent = 494, time = 0
Stikomcki March 10 08:09:16 postfix / smtp [5696]: certificate verification failed for gmail-smtp-in.l.google.com [209.85.225.26]: 25: untrusted issuer / C = U.S. / O = Equifax / OU = Equifax Secure Certificate Authority
Stikomcki March 10 08:09:18 postfix / smtp [5696]: 19E5340054D: to = , relay = gmail-smtp-in.l.google.com [209.85.225.26]: 25, delay = 3.4, delays = 0.16/0/1.6/1.6, dsn = 2.0.0, status = sent (250 2.0.0 OK 1331341758 k5si4254678igb.27)
Stikomcki March 10 08:09:18 postfix / qmgr [5073]: 19E5340054D: removed
March 10 8:10:16 stikomcki imapd: Connection, ip = [:: ffff: 127.0.0.1]
March 10 8:10:16 stikomcki imapd: LOGIN, user = admin@ckiweb.net, ip = [:: ffff: 127.0.0.1], port = [53 268], protocol = IMAP
March 10 8:10:16 stikomcki imapd: LOGOUT, ​​user = admin@ckiweb.net, ip = [:: ffff: 127.0.0.1], headers = 0, body = 0, rcvd = 93, sent = 455, time = 0
March 10 8:11:16 stikomcki imapd: Connection, ip = [:: ffff: 127.0.0.1]
March 10 8:11:16 stikomcki imapd: LOGIN, user = admin@ckiweb.net, ip = [:: ffff: 127.0.0.1], port = [53 269], protocol = IMAP
March 10 8:11:16 stikomcki imapd: LOGOUT, ​​user = admin@ckiweb.net, ip = [:: ffff: 127.0.0.1], headers = 0, body = 0, rcvd = 93, sent = 455, time = 0

You need to use a relay host for outgoing mail. Gmail will accept your mail, but comcast will not.

Here's some information:

http://www.justatheory.com/computers/mail/postfix-and-comcast.html

The above guide works perfectly for me.

Set your postfix to listen to both port 25 and 587 (submission port)

If you don't, you will not receive mail. Mail is received on port 25 and is sent on port 587.

I'm not sure why you're unable to receive mail. It should come through. Are you receiving any error messages when attempting to login to webmail through the EHCP panel?

~
Thanks
OwN-3m-All
EHCP Force Edition

.

I've opened ports 587 and 25
and now I've set postfix to listen to both port 25 and 587 (submission port),
but my server still can not receive email from outside ..? why ..?

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

admin@ckiweb.net

Message will be retried for 1 more day(s)

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://support.google.com/mail/bin/answer.py?answer=7720
[mail.ckiweb.net. (10): Connection timed out]

----- Original message -----

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
d=gmail.com; s=20120113;
h=mime-version:date:message-id:subject:from:to:content-type;
bh=Y1YUTHrkhJJ5rfCN1VvNVNHlVkVKQtJ88qJe8nGZ848=;
b=WF49zU2eKoIv17Tkxuf50AZt4sQKJ+Q+Q898Zob4EYw89kNmFIupV/Mm3Pkhn5zedV
qlSTzDLWjB+Opt2oChR26cd5TZEoL/gFB9Zf7gLL3U+ZPAduJPsvHUD39kr4Rp4fh/L4
d7PYJaMg4c4VBj47M6Hy3MLrxMthiqS74Hc/lg0DRiI1LKm9Yg4n734q2w+8+zCwXof5
sgYghK4qVjQ8Ut1F0wf84grcP5DOjBQqfYGNdJphjeIG2NSw5YWFt+DhrAvuQjAZMF73
sv4YAPlckCbeCB/OS7P+wtf8k18BiM7FXEKgtqVYwpn5UlLvZ9lyMrhw8dTda7QkVhiw
aHTg==
MIME-Version: 1.0
Received: by 10.224.30.206 with SMTP id v14mr3126755qac.18.1331167733190; Wed,
07 Mar 2012 16:48:53 -0800 (PST)
Received: by 10.229.78.219 with HTTP; Wed, 7 Mar 2012 16:48:53 -0800 (PST)
Date: Thu, 8 Mar 2012 07:48:53 +0700
Message-ID:
Subject: safasfasf
From: Akbar Ibnu
To: admin@ckiweb.net
Content-Type: multipart/alternative; boundary=20cf3074d6a6df8f6d04bab0a317

asfasfasfasf

I also experienced it before.
I can send email, but can't receive email.
It is because I use dynamic IP Address.

Reference:
http://www.arschkrebs.de/postfix/postfix_why_dyndns_does_not_work.shtml

My solution for EHCP with dynamic IP Address is to configure Gmail as my mailbox. It can be done by modify MX record.

Please contact me if you need help.
Yahoo Messenger: biroenet (at) yahoo.com