linphone installation problem

In Ubuntu 9.04,
checking for LIBGTK... configure: error: Package requirements (gtk+-2.0 >= 2.4.0 gthread-2.0) were not met
No package 'gtk+-2.0' found
configure: error: Could not find osip2 headers
checking for SPEEX... configure: error: Package requirements (speex >= 1.1.6) were not met:

solution:
aptitude install libexosip2-dev libosip2-dev
aptitude install libglade2-dev libgtk-dev libgtk2.0-dev

i downloaded speex from http://speex.org/downloads/
and builded from source

then i got an error complaining ffmpeg, for video support,
i did: ./configuer --disable-video

make
make install

but linphone did not run again...

Forums: 

wierd, try it again

I use EHCP =)