DNS Issues

I'm having some problems with editing my domain's DNS records. If I add some entries to the DNS and they are somehow invalid, bind does not update immediately or inform me that there are errors. It doesn't update the invalid settings either or complain about it after running the Sync DNS daemon. It seems to update and complain about errors only when Ubuntu is completely restarted. It would be nice if the interface could be updated so that it checks the syntax of our additions. If it's invalid, I'd like to know before I save it. Of course, I'd like to believe that I know what I'm doing when it comes to editing DNS. I added a DNS A record, and that seems to have been causing problems.

More information below:

Here's the log:


Aug 27 21:07:42 eric-desktop named[1039]: dns_master_load: /etc/bind/mydomain.com:30: www.mydomain.com: CNAME and other data
Aug 27 21:07:42 eric-desktop named[1039]: zone mydomain.com/IN: loading from master file /etc/bind/mydomain.com failed: CNAME and other data
Aug 27 21:07:42 eric-desktop named[1039]: zone mydomain.com/IN: not loaded due to errors.
Aug 27 21:07:42 eric-desktop named[1039]: dns_master_load: /etc/bind/mydomain2.com:23: www.mydomain2.com: CNAME and other data
Aug 27 21:07:42 eric-desktop named[1039]: zone mydomain2.com/IN: loading from master file /etc/bind/mydomain2.com failed: CNAME and other data
Aug 27 21:07:42 eric-desktop named[1039]: zone mydomain2.com/IN: not loaded due to errors.

Here's my DNS template with errors:


$TTL 60
@ IN SOA ns3.mydomain.com. {dnsemail} (
{serial} ; Serial, this is www.ehcp.net dns zone template file..
1300 ; Refresh
180 ; Retry
84000 ; Expire
60 ) ; Minimum

mydomain.com. IN NS ns.mydomain.com.
mydomain.com. IN NS ns3.mydomain.com.
mydomain.com. IN NS ns4.mydomain.com.
mydomain.com. IN NS ns5.mydomain.com.
mydomain.com. IN NS dns.mydomain.com.
mydomain.com. IN NS dns1.mydomain.com.
mydomain.com. IN NS dns2.mydomain.com.
ns.mydomain.com. IN A {dnsip}
ns3.mydomain.com. IN A {dnsip}
ns4.mydomain.com. IN A {dnsip}
ns5.mydomain.com. IN A {dnsip}
dns.mydomain.com. IN A {dnsip}
dns1.mydomain.com. IN A {dnsip}
dns2.mydomain.com. IN A {dnsip}
mydomain.com. IN A {webip}
www.mydomain.com. IN A {webip}
mail.mydomain.com. IN A {mailip}
smtp.mydomain.com. IN A {webip}
imap.mydomain.com. IN A {webip}
webmail.mydomain.com. IN A {webip}
ftp.mydomain.com. IN CNAME mydomain.com.
www.mydomain.com. IN CNAME mydomain.com.
mydomain.com. IN MX 10 mail.mydomain.com.
mydomain.com. IN TXT "v=spf1 a mx -all"

{customdns}

* IN A {webip}

I don't see any problems above, but when I delete the A entry of:

www.mydomain.com. IN A {webip}

and run the sync DNS daemon, it works without errors. Why is the above A record causing problems? Also, what's up with the spacing between entries? Is it a spacing issue?

...you can't have these 2 lines at same time:

www.mydomain.com. IN A {webip}
www.mydomain.com. IN CNAME mydomain.com.

CNAME records cannot be conflicted by an A record and vice versa. That's why removing the A record works without errors.