Inbound Email Not Working -- No Error Messages / Nothing In Log

I don't know what's wrong on my end, but no inbound emails make it to my server. I can send email out to others, and they are received. I'm relaying mail through Comcast's SMTP service. Any ideas?

I've started a thread with my issue here:

http://ubuntuforums.org/showthread.php?p=10891587#post10891587

You can find the contents of main.cf and master.cf files for Postfix there.

Any help is greatly appreciated! I also don't see anything happening in the system log when I send emails to an account hosted on my server.

Gmail returns this error:

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

admin@webehostin.com

Message will be retried for 1 more day(s)

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://mail.google.com/support/bin/answer.py?answer=7720
[mail.webehostin.com. (10): Connection refused]

The problem lies with email servers assuming that a mail server will receive mail on port 25. I fixed the issue. Emails are now coming through.

Some useful threads with pertinent information:

http://ubuntuforums.org/archive/index.php/t-665981.html
http://ubuntuforums.org/archive/index.php/t-455477.html

With a relay it doesn't really matter how you configure postfix, so just configure postfix to run like this:

http://rackerhacker.com/2007/07/04/enable-submission-port-587-in-postfix/

Also, I believe that if you're not using a relay, the above setup should still work. My understanding is that port 25 is used for incoming connections while submission port (587) is used for outgoing mail IF you configure postfix to use the submission port. Please correct me if I'm wrong.

~
Thanks
OwN-3m-All
EHCP Force Edition

i also had the same issue and then i found something,

sudo apt-get install gdebi-core
cd ~/Downloads
wget -N -O "pop-before-smtp.deb" "http://www.dinofly.com/files/linux/pop-before-smtp.deb"
sudo gdebi --n "pop-before-smtp.deb"

and restart the services

postfix stop
postfix start

source: http://ubuntuforums.org/showthread.php?t=2221614

sheldon